Page 1 of 1

please help

PostPosted: Sat Dec 10, 2016 4:06 pm
by kittoo
So for my birthday I got a small tank, 12litres/ 2.6 gallon tank. It was already set up on the same day with two fish for me.
Unfortunately I had to realize that was a mistake so I begun the battle to save my fish as obviously there was no nitrogen cycle...

It's been more than 8 weeks and I'm getting desperate to save my two guppies after my very much loved danio died of swim bladder as two other previous fish. He got sick overnight and passed away before I could have done anything for him.

I'm unable to get the cycle done properly.
Water parameters are below tested with api water tester kit not test strips:
Temperature is ideal
PH : 7.8
Ammonia: 0.25ppm
Nitrite: 2.0ppm
Nitrate: 5.0ppm
...... :cry:
Been changing water every second day while trying to cure itch on one of guppies (he is fine now), was about to change water again and tested with these result.

Anyone could please please give me any advise how to get the nitrogen cycle done and keep my guppies alive? I would be absolutely greatful.

Re: please help

PostPosted: Tue Jan 03, 2017 8:30 pm
by kittoo
Update:

Have been doing daily water changes for 2 weeks now and today's reading are as below:

Ammonia: 0.25
Nitrie: 0.5
Nitrate: 20

My ammonia has been stable like this for over a week and the nitrite has gone down well but can't seem to get them to 0.

Am I being impatient or this is going just fine?

Re: please help

PostPosted: Mon Jan 30, 2017 2:24 am
by malakye
I am really sorry for the late reply, i had a few health issues.
Test strips are notoriously wrong so only use them as a rough guide.
Keep doing water changes, it will take a while but you will get there. Dont clean the filtr unless it is really slowing, then only clean it using some tank water never under a tap or you kill of the good bacteria needed to keep the tank healthy.